炒股公式指标网

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 852|回复: 28

通达信短线顶底主图指标 源码 贴图

[复制链接]

5万

主题

0

好友

15万

积分

超级版主

Rank: 8Rank: 8

发表于 2020-1-31 12:17:12 |显示全部楼层
通达信短线顶底主图指标 源码 贴图介绍
股票公式网(www.p61.net)提示:您正在下载的是:通达信短线顶底主图指标 源码 贴图

2020131946055562.jpg

2020131946055562.jpg



CONST(CLOSE),COLOR009955,POINTDOT;
每股公积:FINANCE(18)/1,NODRAW,COLORGREEN;
未分利润:FINANCE(32)/1,NODRAW,COLORGREEN;
所属板块:=STRCAT('所属板块: ',STRCAT(STRCAT(STRCAT('[行业]-',HYBLOCK),STRCAT(' [地域]-',DYBLOCK)),STRCAT(' [概念]-',GNBLOCK)));
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值));
{业绩}
市盈率:=STRCAT(' 市盈率:',CON2STR(C/FINANCE(33),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(净资收益率,毛利率),主营利润率));
MA120:MA(CLOSE,120),COLOR777700;
MA250:MA(CLOSE,250),COLORRED;

NX:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*NX+19*REF(NX,1)+18*REF(NX,2)+17*REF(NX,3)+16*REF(NX,4)
+15*REF(NX,5)+14*REF(NX,6)+13*REF(NX,7)+12*REF(NX,8)+11*REF(NX,9)
+10*REF(NX,10)+9*REF(NX,11)+8*REF(NX,12)+7*REF(NX,13)+6*REF(NX,14)
+5*REF(NX,15)+4*REF(NX,16)+3*REF(NX,17)
+2*REF(NX,18)+REF(NX,20))/210;
牛熊线:MA(牛线,6),COLORGREEN,LINETHICK0;
重心线:(H+L+O+C*3)/6,LINETHICK0;
简底:=H>REF(H,1) AND REF(H,1)<REF(H,2) AND L>REF(L,1) AND REF(L,1)<REF(L,2);
简顶:=H<REF(H,1) AND REF(H,1)>REF(H,2) AND L<REF(L,1) AND REF(L,1)>REF(L,2);
包含1:=REF(H,1)>=REF(H,2) AND REF(L,1)<=REF(L,2);
包含2:=REF(H,1)<=REF(H,2) AND REF(L,1)>=REF(L,2);
包底1:=H>REF(H,2) AND REF(H,2)<REF(H,3) AND L>REF(L,1) AND REF(L,1)<REF(L,3);
包底2:=H>REF(H,1) AND REF(H,1)<REF(H,3) AND L>REF(L,2) AND REF(L,2)<REF(L,3);
包顶1:=H<REF(H,1) AND REF(H,1)>REF(H,3) AND L<REF(L,2) AND REF(L,2)>REF(L,3);
包顶2:=H<REF(H,2) AND REF(H,2)>REF(H,3) AND L<REF(L,1) AND REF(L,1)>REF(L,3);
复底:=IF(包含1,包底1,IF(包含2,包底2,简底));
复顶:=IF(包含1,包顶1,IF(包含2,包顶2,简顶));
底分型:=IF(BARSLAST(CROSS(牛熊线,重心线))>3,FILTER(BACKSET(FILTER(复底 AND 重心线<牛熊线,3),2),1),0);
顶分型:=IF(BARSLAST(CROSS(重心线,牛熊线))>3,FILTER(BACKSET(FILTER(复顶 AND 重心线>牛熊线,3),2),1),0);
STICKLINE(底分型,C,O,2,0),COLORRED;
STICKLINE(底分型,C,O,0,0),COLORRED;
STICKLINE(底分型,H,L,0,0),COLORRED;
STICKLINE(顶分型,C,O,2,0),COLORYELLOW;
STICKLINE(顶分型,C,O,0,0),COLORYELLOW;
STICKLINE(顶分型,H,L,0,0),COLORYELLOW;
DRAWTEXT(底分型,L*0.99,'底'),COLORRED;
DRAWTEXT(顶分型,H*1.02,'顶'),COLORGREEN;
 


股票公式网(www.p61.net)提醒您:股市有风险,投资需谨慎。 下载地址:
购买主题 本主题需向作者支付 2 金钱 才能浏览
回复

使用道具 举报

0

主题

0

好友

838

积分

高级会员

Rank: 4

发表于 2020-1-31 12:21:32 |显示全部楼层
支持,楼下的跟上哈~
回复

使用道具 举报

0

主题

0

好友

798

积分

高级会员

Rank: 4

发表于 2020-1-31 14:03:48 |显示全部楼层
怎样输入股票公式
回复

使用道具 举报

0

主题

0

好友

778

积分

高级会员

Rank: 4

发表于 2020-1-31 15:34:28 |显示全部楼层
股票公式if函数
回复

使用道具 举报

0

主题

0

好友

788

积分

高级会员

Rank: 4

发表于 2020-2-1 13:51:49 来自手机 |显示全部楼层
我擦!我要沙发!
回复

使用道具 举报

0

主题

0

好友

784

积分

高级会员

Rank: 4

发表于 2020-2-1 15:09:09 |显示全部楼层
股票公式if函数
回复

使用道具 举报

0

主题

0

好友

798

积分

高级会员

Rank: 4

发表于 2020-2-1 16:12:33 |显示全部楼层
锄禾日当午,发帖真辛苦。谁知坛中餐,帖帖皆辛苦!
回复

使用道具 举报

0

主题

0

好友

814

积分

高级会员

Rank: 4

发表于 2020-2-1 17:26:53 |显示全部楼层
锄禾日当午,发帖真辛苦。谁知坛中餐,帖帖皆辛苦!
回复

使用道具 举报

0

主题

0

好友

788

积分

高级会员

Rank: 4

发表于 2020-2-2 12:56:11 |显示全部楼层
股票公允价值计算
回复

使用道具 举报

0

主题

0

好友

822

积分

高级会员

Rank: 4

发表于 2020-2-2 14:22:43 |显示全部楼层
股票怎么玩
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

QQ|Archiver|手机版|炒股公式指标网 ( 湘ICP备19017340号 )|网站地图document.write ('');

GMT+8, 2020-9-28 19:23 , Processed in 1.124992 second(s), 34 queries .

Powered by 炒股公式指标网 X2.5

© 2001-2012 炒股公式指标网 Inc.

回顶部